Milkshape Modeling Tutorial for Return to Castle Wolfenstein

this tutorial is saved from the lost paposo.com site

Part I – Modeling Techniques

O.K. Let’s get started. First of all we are using Milkshape 3D version 1.6.4. As of now this is the latest version. You can download it HERE. It’s about 3 Megs. Once you have downloaded the program you will need to register it for you to be able to use all of the import and export functions. You can register it online at the milkshape website. The registration fee is $20. They will email you your registration name/code. When you open up Milkshape go under the Help heading in the menu and enter the code into the registration section. That’s it. Now we are ready to model!

Let’s look around to get familiar with things. Under the file menu we have:

 

      New, Open, Save and Save As – these are all are self-explanatory. Notice the saved milkshape format is the .ms3d file format.

 

      Merge – This allows you to open two .ms3d files together so you can save the two files as one large one.

 

      Import/Export – Here there are a lot of formats to choose from. The ones we are interested in are the Quake III Arena MD3 import and export formats. Most of the models used in RTCW are Quake 3 Arena models. Also notice on the import menu there is a RTCW MDC and RTCW MDC model. These are for importing .mdc files from wolfenstein. The .mdc is a new version of the old .md3 file format which includes some additional compression. Most of the models that use animation are compressed to .mdc format in RTCW. As far as I can tell these models otherwise are not any different than the .md3 format. There is an additional model format used in RTCW which is different from Q3A, and that is the .mds format. This model format (for which Milkshape has no importer/exporter yet) is used for most of the bodies for the player models. The heads are many times in .mdc format. Not to get too far off topic but the .md3/.mdc formats save animation as the movement of the vertex positions. The .mds format saves animation as “bone animation”. The difference is that because the player bodies contain so many animations the .mds format will be smaller overall because of the way the animation frames are saved.

 

    Preferences – If you go to preferences, under the Viewport tab, the first drop down box has a lot of things in it. This is where you can change the appearance of milkshape. The “Ortho” are the three flat gray X, Y and Z views . The “Perp” is the 3D view with the blue background. You can change the color of the grids and backgrounds. You can also change the color of vertexes and faces. Just select the item you want to be a different color from the first drop down box and push the Choose button. The color picker appears and lets you change the color of that item to a new color. “Grid size” changes the grid size in the Persp views. “Point size” changes the size of the vertexes if they are hard to see. Under the Misc tab is some stuff for animation such as the size of the joints and the speed of the animation during playback.

Over on the right side of the screen are a bunch of tabs. These include:

      Model – this is for all your model making tools.

 

      Groups – here you will select and name groups for the model. A group is just a bunch of vertex points on your model. Here you also assign “smoothing groups”.

 

      Materials – this is where we select our textures to skin the model.

 

    Joints – here we assign “bones” to our model for animation.

Now look at the bottom of the screen and see the button called “Anim” at the lower right side. Click on it and you see some stuff at the bottom light up. These are the animation frames. The buttons are for play, forward, reverse, etc. – like a VCR. The two number boxes tell you the number of frames available for animation. The first box means the start frame and the second box means the ending frame. The slider bar across the bottom lets you navigate through the animation. Don’t worry about any of this, we’ll deal with animation later – just recognize that it’s there. You can turn the animation window on and off under Window ->Show Keyframer.

Now look at the top of each of the 4 views. You’ll see 4 boxes. If you can’t go under Window -> Show Viewport Caption. Make sure it’s checked. At the top of one of the ortho views the first box says something like “front” and the next three all have some numbers. Probably you see 4 and –1024 and 1024 in each of the ortho views. In the persp view you see “3D” and the numbers 65, .1 and 4096 or something similar. The first word is the view you are looking at. You can look at the 3D, top, bottom, right side, left side, front or back in the model. The second number is the grid size. You can change the grid size in any of the four views. This doesn’t seem to produce a noticeable difference in the ortho view so just leave it. In the perp view it changes the Field of View of the camera so you get a different “look” to the model. The other two numbers are similar to “cubic clipping” in GTKRadiant. The second number is how far away you can get before the viewer “clips” the model so you can’t see it. The first number means how close to the model you can get before you can’t see it.

Normally you don’t need to fool with any of these numbers.

One other thing. Go under the Window->Viewport and you can change the number of views and they’re alignment. It’s better to use 3 views when skinning and 4 views for modeling. You can also put the tabs on the left side of the screen instead of the right side under Window -> Controlpanel -> Left/Right.

And if you want to increase the size of one of the views just right click on the view and select “maximize”. Click it again to turn it back. This is very useful.

Finally version 1.6.4 of Milkshape comes with the XP look to it if your using XP. If you don’t like it open up the Milkshape directory and find the file called “ms3d.manifest” and rename it. This will get rid of the XP buttons.

Wow. Let’s do some modeling…..

 

 

Vertex modeling

The best way to understand some of the other menu commands is to use them. So let’s get into it.

Here I’m going to try to do a little modeling on a helicopter. Follow along as it will get you to become familiar with the most import uses of Milkshape. This is not an extensive coverage of everything that can be done will Milkshape but will definitely give you an understanding of what’s going on.

You can model anything you want. Many people already know what they want and can do it from their imagination. That’s fine. But maybe you want to model from a picture of something you have to help you. The best pictures to model from are a perspective view – like a top, front, side view. Angled pictures don’t work too well because they are disproportionate. With an angled picture you have to free-hand model it. Let’s pick a good picture. How about this one:

This is a model of a Seaking helicopter I got off of THIS website. Check it out. It has some good stuff. All those line drawings are good to use. You can do a search for “technical illustration” or “line drawing” or “blueprint” ect. to find these kinds of pictures.

O.K. now we want to break up this picture into three parts. A top view, a front view and a side view. We can do this in photoshop or paintshop.

Now we need to go into milkshape and change the ortho views to correspond to the 3 pictures we made. Find the dropdown boxes at the top of each ortho view and change them so that one of the boxes has the word “top” , another the word “front” and the other the word “right” as the picture we have shows the top, front and right side of the helicopter.

Go to one of the ortho views and right click on it and select “change background image”. Select the background image which corresponds to the view. (i.e. top view of the helicopter for the word “top”, etc.). It should look like this:

If you click cancel after you have previously selected an image, the background image will be cleared.

WOW. This looks cool. But what do we do from here? Let’s now build the model by vertices.

At this point you could attempt to use cylinders and boxes to try and build the model but I think that it would be better if we used vertices.

How do you do that?

Under the Model tab on the right click on the box that says vertex. This box allows you to place vertices on the ortho grids. Now zoom in to the side view of the picture.

Oh, I almost forgot. You move around in milkshape in the following manner:

      Control + holding left click ->lets you move around in each view

 

      Shift + holding left click ->lets you zoom in and out in each view

 

      Mouse wheel -> lets you zoom in all 4 views as well

 

      Shift + Mouse wheel -> lets you Super zoom (good for when you in close)

 

    Holding left click in the persp view ->lets you rotate the model in 3D (as you probably figured out)

If you get stuck and can’t zoom, go to the Model tab on the right and click the “Move” button and try it again.

Now that we know how to zoom in, let’s zoom in onto the side view. Over on the right make sure your under the Models tab. Press the big button that says “Vertex”. Now click on the grid. A little red dot appeared. That’s a vertex. Exciting. Now put some more. The idea here is to draw a straight line from that vertex along the outline of the picture until the line has to change directions. At that point put another vertex. It is not really important where you put the vertices on the picture. Just remember that the more vertices you put – the more sides to the model you will make in the end – and the more complex it will be later.

Let’s see what we have. Something like this maybe:

Looks great! Once you have vertices all along the outline of the picture we are read for some triangle building.

What we want to do now is to build some triangles which correspond to the vertex points that we laid down. We do this by selecting, on the Model tab at the right, the “Face” button.

O.K. what is the “Face” button. This button allows you to connect the vertex points to make triangles (or faces) from them.

Go back to the view with all of your vertex points. Now click on three vertex points that you want to be a triangle. You should have something like this:

You are building triangles! Great. Now continue until you have the entire face built out of triangles. Remember that it is important that every vertex point be associated with a triangle. You don’t want any empty triangular spaces on the model and you don’t want overlapping triangles. You have to do a little thinking here if the vertexes are complex. A single vertex can be associated with a lot of different triangles, however. Check the 3D view to see how you doing now and then.

 

Fixing the black triangles

Once your done you should now have 1 side to your helicopter! It looks a little weird though. It looks kind of grey with black splotchy patches. That’s because when you made your triangles out vertex points you didn’t click the vertices in the right order. Oops. It’s O.K. You probably have something that looks like this:

Yuk. Doesn’t look good at all. Well we definitely need to fix those black areas. If you don’t the model will not texture correctly later on. A black triangle means an “invisible side” to Radiant later on, and your model will show up with a bunch of triangular holes in it. (This can be useful if you want a section of the model made to be”hollow”). So, how do we fix them? On the right hand side under the Model tab, push the big “Select” button and also the little “face” button at the bottom like this:

This means you want to select faces on the model. As a vocabulary note, faces, triangles and surfaces are all the same thing. Notice that there are two checkboxes at the bottom. We will not use these but the first one “ignore backface” means that when your facing the model in a direction (i.e. from the left) you will not select faces that are showing a black face (the backface) in that direction.

We need to know a little about selecting a deselecting:

      Shift + left click or left click drag -> selects

 

      Shift + right click or right click drag-> deselects

 

      Shift + left click drag -> adds to your selections while retaining your already selected items

 

    Shift + left click drag -> removes from your selection without loosing your other selections

This is true for all kinds of selection.

Oh. Notice that it’s hard to see where the black triangles begin and end in the 3D view. They look sorta blended. That will make it hard to select them in the Ortho views. Right click the 3D view and select “Flat shaded”. Wow. Now the black triangles pop right out. This view is great for finding the backwards triangles.

With the big “Select” and the little “face” buttons pushed now go a select a triangle you think might be a black one in the Ortho view. The face you slected now has a red outline. Now with that triangle selected go to the menu under Face -> Reverse Vertex Order. Your black triangle changed to a light gray! That’s what we want. If you made a gray triangle black (check your 3D view) you need to go back and try it on a different face. Hit Cntr+Z to undo.

What we’re trying to do is put all the light gray faces on one side and all the black faces on the other. Keep selecting triangles and changing their vertex order. If the side looks a better in the 3D view keep it. If you made it look black then undo it by pressing Control + Z. Keep it up until you have a light gray side on one side and a darker gray/black side on the other. You should end up with something like this:

The light gray side is the “outside” of the model and the dark side is the “inside” or the “invisible” side of the model. You always want the outside part showing in the finished model. (Unless you want that face to be invisible).

 

Turning it into 3D

Looks, well, like a paper cut out. Oh, well. Not there yet. We need to turn this into 3 dimensions.

First we need to go over to the Model tab again. Before we can make our paper cut out into a 3D model we need to select the whole thing and move it around a little. So go back to the Model tab and push the “Select” button and also the little “face” button at the bottom, just like before. Now left click drag and select the whole model in the Ortho view. Everything should light up red. Good. Now lets move the model over to one of the sides of the helicopter picture shown in the “front” view. We’ll do this by (while everything is selected) pushing the “Move” button on the right. Now look at the bottom 3 boxes at the bottom of the Model tab that appeared when you pushed the “Move” button. They say X, Y and Z and some numbers. These boxes restrict movement in a certain direction. If the button is “pushed” that means you can move the model in that axis. If it is not, then, well not. The number boxes are used to move the model in a direction precisely. You would type in a number and then hit the little “move” button next to it. Turn off the Y and Z axis by pushing “out” those buttons, as we will only move the model in the X axis.

Now move the model in the “front” Ortho view over to one side of the helicopter.

Let’s turn this piece of paper into something more 3 dimensional. To do this we need to “Extrude” our flat plane. So with the model still selected click on the “Extrude” button. Notice that you still have the same X, Y and Z buttons at the bottom. Of course these restrict the ability of the model to be extruded into those axis’. Notice the number boxes as before. These are used to extrude an exact amount – like the move button. Also you see a new check box called “Auto smoothing group”. Leave this on as it will assign your new faces automatically to smoothing groups. (We’ll talk about them later – don’t worry abou them). Lets turn Now, lets turn off the Y and Z axis as we are only extruding into the X-axis.

In one motion you need to drag the side of the model out along the X-axis. Cooool. Now you have something in three dimensions. Notice that if you stop and then start again while dragging you get a second set of triangles. Bad. Bad. Bad. Hit Control + Z and do it again until you stretch it out in one smooth movement. Those extra triangles mean extra faces on the model.

Oh oh. Look at that ugly black triangle on the nose. We’ll need to fix that. But you already know how. You’ll need to go though the model and find the rest of those black triangles and reverse their vertex orders until everything looks O.K.

Once you’ve fixed all the evil triangles you ‘ll want to scale down the size of the helicopter that we made to about half of the helicopter size so it looks realistic in wolfy. (Mine ended up a little big). Go select the entire model like you did before. Select all the faces and then click the scale button. Notice those X, Y and Z boxes again. Because we just want to scale in the X direction turn off Y and Z.

Hey, check out the radio buttons too. They say “center of mass”, “origin”, and “user point”. Depending on which one you select your model will scale in/out from that point. Center of mass is exactly that – the center of what you have selected (there really is no mass associated with a model – physically speaking). Origin – is the 3 pronged colored axis at the center of the “model space” in the 3D view. User point means from wherever you click and hold on one of the ortho grids. Each of these can be useful; you’ll have to play around with them.

Now with everything selected and ready – left click on the “front” ortho view and drag it in the direction you want to scale it. CRAP. It went way too fast. That’s O.K. keep practicing. Zoom in if it helps. The farther your zoomed out the faster moving and scaling, etc. will be. Also you can use that number under the X-axis button. Type in 0.5 and then hit the “scale” button. That should scale the whole thing by half in the X-axis direction.

Notice that you have the “outside” light gray on the outside of the model and the “inside” dark black on the hollow inside of the model. If you don’t, you extruded the model in the wrong direction! Oops. You’ll need to go back and extrude it again.

 

Merging the overlapping vertices

Notice that the other side of the model is “hollow”. That’s O.K. That’s why this is only half of the helicopter!

Go and “Select” all the faces of the model. Now with everything selected again, go and hit the Edit -> Duplicate selection from the menu. You can see in the menu that you can also use the hotkey Control + D.

Ahhh. Don’t touch anything!!!! Once you have duplicated the selection you MUST move it out of the way, or you will have duplicate sets of vertices and faces on top of each other. Click the “Move” button and move it in the X-axis over to the side.

Great. You have 2 helicopter halves. But they don’t match. You’ll need to mirror image the one you have selected. Go to Vertex -> mirror left/right in the menu. (You should have the half selected you want to mirror).

Now you have the other half of the heli. Cool. Now move it over in the X-axis so that it’s on the correct side. Disable the other axis’ when moving as it will make it more difficult to line up both sides if you don’t.

Carefully move the whole selected half of the fuselage over to the other one. Match up the vertices in the middle as best as you can. Zoom in if it helps. You now have two sets of vertices in the middle of the helicopter that overlap each other. Normally you wouldn’t care less. But not only does it increase the number of vertices of the total finished model but it makes these funny looking sparklies in the middle:

To get rid of those sparklies you’ll need to fuse the duplicate vertices in the middle of the model. Go hit the “Select” button under the Model tab and now at the bottom click the “vertex” button. Your now going to select the vertices to fuse.

Control + left click drag to select a vertex in the “side view”. Notice how you probably have 3 vertices selected, not just one. You’ll need to deselect the vertex on the left and the one on the right and keep the one in the middle highlighted red. Do a Control + right click drag over the left vertex. It turned white. Now do it with the other vertex on the right. O.K. you should have only the one in the middle selected and red. Now go to the Vertex menu and select “Snap together”. This will not merge the vertex points. It will however, make sure the points are exactly on top of each other. If the vertices are not EXACTLY on top of each other they will not merge, so by “snapping” them together we will be sure they will merge.

Before you merge that vertex point go to Tools -> Show Model Statistics in the menu. This box gives you the statistics about your model. Take a note of the number of vertices in the model.

Now go back to the Ortho view and with that vertex point selected that you just snapped together, go and do a Vertex -> Weld Together in the menu. (Notice the hotkey Cntrl + W (for weld…….)). Go back to the statistics menu. Your model has lost a vertice! This means your fusing those two halves together.

Are you frustrated at having to deselect those stupid vertices you didn’t want? There is a way to hide them so you don’t select them. With the “Select” and “vertex” buttons selected you and select all the vertex points you want to hide. Now under the menu choose Edit ->Hide selection. They’re gone! Now you don’t have to worry about selecting them. You can make them reappear by selecting Edit -> Unhide All in the menu. (This can be done with faces if you select them instead).

Select those middle vertices and keep snapping and welding them together until you have done it with all the vertices in the middle on the model.

Now that you’re done you model should no longer have those “sparklies”. See…..

Great! You now have the fuselage for the helicopter. It’s looking good already. Be sure to check for the black faces in the 3D view.

 

Making it look realistic

Is it just me or does this model look a little square. No very realistic huh? But the important part is done. All we have to do now is just pull the vertex points on the model to create the desired effects of curving lines, etc.

We do this by going back and pushing the “Select” button like you did before and choosing the “vertex” button at the bottom. You can now left click on any vertex you want to pull. Be sure you’re only pulling 1 vertex! Look at your other views just to make sure you don’t have others selected. If you do have other selected you don’t want just right click them to deselect. Use the background images to help you align the vertex point scorrectly.

This is really why you need a good background picture. It really helps when your stretching those vertices. Now we have one last thing before for you become a certified Milkshaper.

Lets look at some face subdivision.

Check out that rotor thingy on the top of the helicopter. Looks complicated. You could make a cylinder to put up there and stretch the vertices of the cylinder. OR…. You could subdivide the faces on the top of the helicopter and stretch it. How do we do that?

First of all lets select two triangles and the top of the helicopter that we want to make more complex. Be sure you only have two triangles selected! Check your views! Use the “ignore backfaces” checkbox if it helps. Now in the menu select Faces ->Subdivide 3.

Ooooo. Now your triangles look different. You subdivided each triangle into 3 triangles. Neat. Why did we do that? Because we are going to use that extra vertex point in the middle. Go and deselect everything. Now grap the new vertices we created at the center of the triangles and the two vertex points that joined the original two triangles.

In the front view go a head and move the vertex points up along the Y axis. Check out the 3D view. You made a rotor mounting!

You did it!!! Now you have used most of the features of milkshape and have a good idea on how to create your own models. Remember that you can use pictures (as we did here) or you can just do it from your imagination.

Now on to Part II – how to skin and export your beautiful model.